Not enough RAM? I have 1 gig!

Real time World War II combat simulation

Post by Guest » Sat Dec 03, 2005 8:06 am

I can't get the game to run either for the same reason. Just found it by accident and wanted to give it a try. I was a big Close Combat fan so I wanted to see how this game worked.

I too have an older (ancient) machine. It's a PII-450 with 128 MB of ram and a Voodoo II card with (I think) 8MB of memory. The OS is Win98SE. I can run some pretty big games on this machine including flight simulators, but Firefight will not work.

Andy Brown
Posts: 262
Joined: Wed Dec 08, 2004 9:30 am
Location: Christchurch, New Zealand

Post by Andy Brown » Sat Dec 03, 2005 11:23 am

Try setting the graphics to 16 bit. I seem to remember that I had difficulty running Firefight on a machine with a spec similar to yours and that fixed it. For some reason, Firefight didn't like the low spec/Win98/32-bit colour combo.

Worked for me. Might work for you.



Post by Guest » Mon Dec 12, 2005 12:04 am

Hoefully this problem gets resolved. I love firefight, but I'm not changing to 16-bit everytime I want to play it. And I certainly won't pay for it until this particular problem is resolved.

Posts: 297
Joined: Thu Dec 16, 2004 8:56 am

Post by Quitch » Mon Dec 12, 2005 7:57 pm

The problem is that you've only 8MB of on-board graphics memory, and the bitmap in 32bit mode takes up more than 8MB of space. It's not a "problem" as such, it's just that your machine doesn't meet what it appears the minimum requirements of this game are.


Post by Guest » Tue Dec 13, 2005 12:58 am

I have 1 gig of RAM and a 256meg Video Card. Surely that should be enough to run the game.

User avatar
Sean OConnor
Posts: 1318
Joined: Fri Sep 03, 2004 7:47 am
Location: Cambridge, UK

Post by Sean OConnor » Tue Dec 13, 2005 10:06 am

Anonymous wrote:I have 1 gig of RAM and a 256meg Video Card. Surely that should be enough to run the game.
To be totally honest, I don't know why Windows chokes on some machines when I call the function:

CreateCompatibleBitmap(hdc, 3400, 3400);

to make the offscreen world bitmap. It works fine on my 2 year old computer (at 32 bit colour) which just has a simple video card on the motherboard, and it even works on my old Pentium II 266 at its maximum of 16 bit colour.

I just call this function and Windows either says "OK, done it" or "sorry, failed to create the bitmap" but without any explanation as to why.

At 32 bit colour the bitmap should take up 4 x 3400 x 3400 bytes which is 44MB. Sure, this is quite big but I'd have thought any modern computer ought to able to handle it, especially if you've got 1GB of RAM and 256MB on your video card!

My only guess is that maybe you have a lot of other programs eating up memory? On Windows XP you can press CTRL + ALT + DEL to bring up Windows Task Manager and click on the Processes tab to see who is eating all your memory.

Also, from version 3.99r onwards I've reduced a lot of the memory Firefight needed by only loading tank graphics as they are needed in each individual game, rather than having all of them loaded at the beginning when you start the app.

Posts: 297
Joined: Thu Dec 16, 2004 8:56 am

Post by Quitch » Tue Dec 13, 2005 10:55 am

Those of your with issues, do you have an existing wallpaper? Do you use Active Desktop (right-click the desktop, go through Active Desktop and see if it is marked as enabled)?


Post by Greg » Sun Dec 18, 2005 2:12 am

Hi, I have the same problem. My specs are: CPU: 2.4GHz, RAM:512MB, Graphic Cards Mem: 128MB, OS: Win98SE. I have two computers with simailar specs. I common factor is win98SE. Both computers have no background application running and no wallpaper. I am a computer programmer so I know a little about these problems. I can get the game started by reducing the windows color depth to 256 colors, then starting the game, then chaging the color depth back to 32bits. However when you do this the colors are odd (probable still only 256) but at least the game started. I hope you solve the problem as I loved the Close combat series and this looks similar.

Posts: 297
Joined: Thu Dec 16, 2004 8:56 am

Post by Quitch » Sun Dec 18, 2005 9:10 am

98SE tends to require a restart once you bump up the colour setting, otherwise you get slightly wierd colours as you noted.

Right-Click the desktop and go through Active Desktop. See if Active Desktop Enabled is checked.


Post by Machine2 » Sun Mar 05, 2006 5:11 pm

I have two PCs and both get the same ram error. One is old, with win98se P166 and 64Mb ram(!) and the other newish with win98se, 1.8GHz and 512Mb ram.

Now I know why the old PC won't work, there's no way it is going to create a bitmap of 44Mb size!!

But my newer PC should do it!!

Maybe with win98se you could allocate a block of memory specifically big enough, before creating the array? That's how we used to do it in the dos days, always have to reserve memory for those big arrays. There's obviously a problem wth allocating it on the fly.

User avatar
Posts: 4
Joined: Wed Mar 01, 2006 2:42 pm

It's getting weirder ...

Post by Manie_de » Mon Mar 06, 2006 9:22 pm

Hi there !

Bought Firefight yesterday, installed it and then played it under Win XP with 32 bit colours and 1 gig RAM.

Played another game today and afterwards I played something else.
Was bored after some time and wanted to get back to my campaign in the Pacific, but NOW the game gives me the famous "low RAM" message !

Don't want to boot my pc now, but if this will work I'll let you know.



Hi again !

Rebooting worked for me and now I'm able again to start Firefight.

Post Reply