[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4762: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4764: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4765: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4766: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
Sean O'Connor's Games • View topic - Beta version of new Slay ready for testing!
Page 1 of 6

Beta version of new Slay ready for testing!

PostPosted: Wed Oct 26, 2011 3:11 pm
by Sean OConnor
It took a lot longer than I expected but here is the beta version of the new Windows Slay: I'm really pleased with how it's turned out but I still haven't added back networking to it yet. This version is fully functioning but it will stop working after a few weeks. Please let me know what you think and be as critical as you like!

I'm really interested to know what people think of the new AI. I think in some ways it's easier as the computers now know how to bankrupt enemy territories so they lose a lot of money bankrupting each other. I think the middle section of the game is harder now though. I've found that in the old version if you got any half decent territory you'd go on to beat much larger enemy territories. Now once the computers get a large territory it's very difficult to beat them.

PostPosted: Thu Oct 27, 2011 7:25 pm
by the space predator

PostPosted: Fri Oct 28, 2011 9:18 am
by Sean OConnor
This is exactly the sort of problem I was worried about by using DirectX! MS has made a real pig's ear of using DirectX unless you want to ship the entire DirectX installer with every download or CD/DVD.

I've put a new beta version up at the same link. Could you try installing that and let me know what the error message now is in the title of that message box? And could you let me know what version of Windows you have got?

PostPosted: Fri Oct 28, 2011 2:57 pm
by the space predator
I'm now able to launch the game. :)

PostPosted: Fri Oct 28, 2011 3:17 pm
by the space predator
I have find a strange glitch.
Image
when I try to move my guy, I am able to take the AI's guy pointed by the red arrow. Of course, I can't move it, but I guess that it is not normal to take an AI's guy instead of our own...

PostPosted: Fri Oct 28, 2011 5:54 pm
by Sean OConnor
Thanks Space Predator! That's exactly the sort of bug I would never have spotted myself as I'd never tried picking up enemy pieces! Got that fixed now and it's up on the same link and says "Beta #3" in the game's title now.

BTW how did you fix the DirectX issue?

PostPosted: Fri Oct 28, 2011 9:06 pm
by Fusion_power
I ran through it once to see how it plays and found a few quibbles about contrast and about moving men. I spotted the changes to the AI very quickly. Give me a few days to see how some specific games play out and I'll post something about it.

DarJones

PostPosted: Fri Oct 28, 2011 9:08 pm
by Wakke
I redownloaded the setup file, but I still get the same error window Space Predator mentioned:


---------------------------
Couldn't create DirectX device
---------------------------
Sorry, but this game needs DirectX 9 to run at a decent speed.

Would you like to download and install DirectX 9 from
Microsoft's website?
---------------------------
Yes No
---------------------------

When I select Yes and download the latest direct X, it states I already have the latest directX version. When I select No, nothing happens.

PostPosted: Fri Oct 28, 2011 10:08 pm
by Sean OConnor
I've made a slight change which might fix the DirectX problem. It also shows more accurate error messages too. Could you try again with the new download (beta #4) and let me know if that still doesn't work and what the error message is now?

PostPosted: Sat Oct 29, 2011 9:12 am
by Wakke
I redownloaded the install, but I still get the same error message (title and content the same). I'm using Vista Home basic btw.

PostPosted: Sat Oct 29, 2011 10:45 am
by Sean OConnor
Could it be that your graphics card is old and just can't run DirectX? My old XP laptop's video card burnt out so I had to disable it and now it can't run DirectX and I get that same error message that you are seeing.

The only other thing you could try is making sure your graphics drivers are up to date.

I've uploaded beta #5 which explains the error messages better. You've obviously got the DirectX DLLs installed but it looks like when they run and ask your graphics card to create the DirectX device it says no.

The error messages will no longer ask you if you want to install DirectX if it is already installed but it's failing to create the device.

PostPosted: Sat Oct 29, 2011 12:21 pm
by Wakke
New error msg:

---------------------------
Couldn't create DirectX device
---------------------------
There seems to be an error running DirectX9. Either:

- your graphics card cannot run DirectX9
- you need to update your graphics drivers
---------------------------
OK
---------------------------

This is not my regular gaming PC, in dxdiag it says 'standard VGA grahpical adaptor'. It played the older slay version just fine, though.

PostPosted: Sat Oct 29, 2011 12:59 pm
by Wakke
I was able to install it on an other PC (vista laptop), but when in game, the screen would very rapidly flash (alternating between the normal screen and a completely white screen). Also, while moving the mouse, the screen would be completely white all the time (instead of flashing).

PostPosted: Sat Oct 29, 2011 11:39 pm
by the space predator

PostPosted: Sun Oct 30, 2011 1:47 am
by Fusion_power