New Bug

A boardgame of world domination

New Bug

Postby gwydion » Fri Oct 22, 2010 12:02 am

I recently updated the game through the apple app store to version 2.5. however when i go to place my armies in my countries the game does not add them to the country and i lose them. also after i place an attack i am unable to move the map to make a second attack from a different country. I really enjoy this game. it helps me get through my boring day. but now i am unable to play it. please help. is there a way i can get the older version back?

thanks
gwydion
 
Posts: 1
Joined: Thu Oct 21, 2010 11:55 pm

Postby badson » Fri Oct 22, 2010 11:14 am

I have the same issues with the latest version. It's unplayable now. I'm on an iPhone 3g with 3.1.2 OS.
It seems like the games start out ok, but after six or more turns the controls degrade. I've had this issue on four or five different maps and noticed it first on Twin Islands. The new star map that is a solar system seems to be the best to recreate the issue.
badson
 
Posts: 3
Joined: Fri Sep 15, 2006 9:01 pm

Postby Sean OConnor » Sat Oct 23, 2010 10:02 am

I'm really really sorry about this - I blundered pretty badly there. In my haste to get an upgrade to the corrupted Skyland, Esterbrook and England on the AppStore I accidentally sent off a version that was being worked on to allow more than 128 territories. In this version (2.5) it thinks the sea is a territory. :(

The technical reason is I'm using unsigned numbers now instead of signed so the sea used to be territory -1 but is now territory 255. The code for checking which territory you clicked on sees that you clicked on territory 255 and doesn't realise that that is sea.

I spotted the problem almost as soon as version 2.5 went live and I sent off version 2.6 on the 20th October. It's still taking Apple about a week to approve an update so (if there are no issues) I'm hoping the update will go live around the 27th.

Sorry again for the problem and I'll try and do more testing before I send off updates in the future.
User avatar
Sean OConnor
 
Posts: 1298
Joined: Fri Sep 03, 2004 7:47 am
Location: Cambridge, UK


Return to Conquest

Who is online

Users browsing this forum: No registered users and 1 guest

cron