Page 1 of 1

Weird bug - wouldn't let me complete mission

Posted: Fri Aug 17, 2007 8:41 pm
by Im1985
Okay, so I was on a 'find the coloniser' mission, destroyed the enemy squadron, then had my wingmates help me scour the sector for the coloniser. #2 finally finds it, but as soon as he does, the 'mission over' text pops up and doesn't let me go and kill it.

The coloniser wasn't really near the sector edge, never mind beyond it, so I don't know what caused this. All my ships were still alive and I didn't eject or hyperspace or anything. I've attached a screenshot. Which incidentally also lets you see my favourite low-level custom ship - the Skeleton Key.

Image

Posted: Fri Aug 17, 2007 8:43 pm
by Sean OConnor
The mission gets ended if no missiles are fired for 30 (as far as I can remember!) turns. I added that just as a safety mechanism so missions couldn't go on forever.

If you are searching for an enemy ship try firing off a missile every ten turns or so and that will stop it from automatically ending.

Posted: Fri Aug 17, 2007 11:50 pm
by Legacy
Sean O'Connor wrote:The mission gets ended if no missiles are fired for 30 (as far as I can remember!) turns. I added that just as a safety mechanism so missions couldn't go on forever.


Unfortunately, sometimes it drops the ball on actually preventing the endless patrol. Namely, if enemy combatants are roaming about somewhere.

Posted: Sat Aug 18, 2007 4:26 am
by Old Man Johnson
If you're really trying to conserve missiles, you can count off 29 turns and then fire a missile. But 20 is a safe number and is usually what I stick with.