iPad version sound is always at max volume

Conquer the island
Post Reply
Martoon
Posts: 2
Joined: Thu Nov 17, 2011 2:27 am

iPad version sound is always at max volume

Post by Martoon » Thu Nov 17, 2011 2:43 am

This was mentioned in this thread, but it was buried down in the thread and was posted quite some time ago, so I suspect Sean hasn't seen it.

On my iPad 2, the game sounds are always at full volume, regardless of what I have the iPad volume set to. So the only options are to have the sound very loud (which is annoying to other people around), or to have the sound muted entirely. I don't know if it does this on other iOS devices (I just have the iPad 2).

User avatar
Sean OConnor
Posts: 1299
Joined: Fri Sep 03, 2004 7:47 am
Location: Cambridge, UK
Contact:

Post by Sean OConnor » Thu Nov 17, 2011 12:25 pm

Sorry about that! I use the very basic sound player on iOS and in earlier versions of iOS that was controlled by the volume switch, but they changed that around 4.0ish.

I had a quick search in some forums and found this:

"I had the same problem getting SystemSound to respect the volume buttons but found a setting in "Settings"/"Sounds"/"Ringer and Alerts"/"Change With Buttons" that was "OFF" by default. Switching that to "ON" made it work."

As I do updates I'll start using OpenAL to play the sounds rather than the simple iPhone sound player.

Martoon
Posts: 2
Joined: Thu Nov 17, 2011 2:27 am

Post by Martoon » Thu Nov 17, 2011 3:19 pm

Sean O'Connor wrote: "I had the same problem getting SystemSound to respect the volume buttons but found a setting in "Settings"/"Sounds"/"Ringer and Alerts"/"Change With Buttons" that was "OFF" by default. Switching that to "ON" made it work."
Awesome. That took care of it. Thanks! :)

Post Reply